EVGA

Can anybody help with this 850 G2 problem

Author
juanmigael
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2018/07/09 17:26:39
  • Status: offline
  • Ribbons : 0
2018/07/09 18:05:51 (permalink)
Hello,  I am new here just signed up.  Well I built a workstation about 18 months ago, and I used the 850 G2 psu.  It has been good, love the design, packaging, etc.  Only problem is it went south on me about a week ago, nothing! Took out the DVM and verified the 120 vac input is good, so I was in a hurry to get it back up and running and I bought the same unit on ebay used for about half of what another new one would cost.  So, I received the used 850 psu today installed it and Nada! Its doing exactly the same as my original, Nada.  Any thoughts, advice, but no Hey dumb-ass!  Already feeling kinda small...thanks
#1

13 Replies Related Threads

    Sajin
    EVGA Forum Moderator
    • Total Posts : 29608
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 174
    Re: Can anybody help with this 850 G2 problem 2018/07/09 18:34:29 (permalink)
    You sure the psu is the issue? If yes, you should have rma'd the unit instead of buying a used one.


    #2
    bob16314
    CLASSIFIED Member
    • Total Posts : 4877
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Transylvania
    • Status: offline
    • Ribbons : 350
    Re: Can anybody help with this 850 G2 problem 2018/07/09 18:54:55 (permalink)
    Your 850 G2 should have came with a tester that goes on the 24-pin connector to turn it on without it being connected to the mobo..Or you can use a paperclip/wire to turn it on..That will quickly determine if the unit basically works..If it doesn't turn on, it's no good if the AC input from the wall is OK.
     
    See How do I test my power supply? and also the link for Advanced Voltage Testing and ATX power specification/pinout in the EVGA FAQs.

    * Cooler Master NV-334 * ASUS P8Z77-V LE PLUS * Intel i7-2600K @ 5.0GHz * Corsair H80 * Seasonic M12II 750W * 4x4GB 2133MHz Patriot Viper Xtreme * EVGA GTX 760 SC * 2 x WD 500GB Caviar Black RAID 0 * 2 x Toshiba DT01ACA 500GB * Dual-boot Win7 Home Premium 64-bit/Win10 Home 64-bit (Winver 1803) *   
     
    "If it ain't broke, fix it untill it is"


    #3
    EVGATech_JeffP
    EVGA Tech Support
    • Total Posts : 283
    • Reward points : 0
    • Joined: 2017/02/20 09:03:47
    • Status: offline
    • Ribbons : 0
    Re: Can anybody help with this 850 G2 problem 2018/07/09 21:45:16 (permalink)
    Try booting your system without the graphics card installed. 
    #4
    notfordman
    Omnipotent Enthusiast
    • Total Posts : 8266
    • Reward points : 0
    • Joined: 2007/08/09 23:52:23
    • Location: In a van, down by the RIVER!!!!!!!!
    • Status: offline
    • Ribbons : 20
    Re: Can anybody help with this 850 G2 problem 2018/07/10 11:13:31 (permalink)
    Juan, follow the advice given above. You should also be able to RMA the original PSU, if it was registered it will make it a bit easier. Also report back with your findings, I'm curious about your issue. GL! 
    #5
    juanmigael
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2018/07/09 17:26:39
    • Status: offline
    • Ribbons : 0
    Re: Can anybody help with this 850 G2 problem 2018/07/10 18:17:56 (permalink)
    thanks, good suggestion, but that is not it.  I tried the network board as well.  I have limited time to trouble-shoot as I am trying to complete an online masters program, just my luck that the main computer I use goes down in my (hopefully) last term. When I saw your email I said to myself thats gotta be it!  I have learned a lot from this site in just 24 hours, any more good suggestions?  Obviously I'm eating a lot turkey...as it was not the psu - but I can turn the extra psu pretty fast on ebay. 
    #6
    juanmigael
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2018/07/09 17:26:39
    • Status: offline
    • Ribbons : 0
    Re: Can anybody help with this 850 G2 problem 2018/07/10 18:24:10 (permalink)
    thank you very much good info. I feel humble at this point as it was not the psu and I am getting a lot of help from this site. 
    #7
    juanmigael
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2018/07/09 17:26:39
    • Status: offline
    • Ribbons : 0
    Re: Can anybody help with this 850 G2 problem 2018/07/10 18:29:00 (permalink)
    thanks for your suggestion. Well I was wrong it is not the psu and if I did rma then that would have been a waste.
    #8
    juanmigael
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2018/07/09 17:26:39
    • Status: offline
    • Ribbons : 0
    Re: Can anybody help with this 850 G2 problem 2018/07/10 18:37:35 (permalink)
    yes thanks. So far the psu is good(both), the video board, and the net interface board were isolated. Biggest problem is I don't have a whole lotta extra time for trouble-shooting, just trying a few things here and there. Thanks for the encouragement.
    #9
    Sajin
    EVGA Forum Moderator
    • Total Posts : 29608
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 174
    Re: Can anybody help with this 850 G2 problem 2018/07/10 18:43:08 (permalink)
    Sounding like a motherboard issue at this point.


    #10
    juanmigael
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2018/07/09 17:26:39
    • Status: offline
    • Ribbons : 0
    Re: Can anybody help with this 850 G2 problem 2018/07/10 19:31:23 (permalink)
    yep unfortunately. Any other comments for this observation?
    #11
    juanmigael
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2018/07/09 17:26:39
    • Status: offline
    • Ribbons : 0
    Re: Can anybody help with this 850 G2 problem 2018/07/14 10:16:30 (permalink)
    I have not had much T-shooting experience with desktops, obviously, but it appears to be a bad, but is there a way to know 100% sure before I go out and purchase another MB?  Do you usually have to replace the processor when replacing a MB or is it a just a matter of fate?
    #12
    EVGATech_BennyM
    EVGA Tech Support
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2018/05/23 12:05:10
    • Status: offline
    • Ribbons : 0
    Re: Can anybody help with this 850 G2 problem 2018/07/14 10:33:29 (permalink)
    Hello,
     
    If you are needing to replace a mother board it is always best to take a look at the cpu socket to see if there are any bent pins. If there aren't any then depending the issue you are having it could be a matter of fate. 
    #13
    juanmigael
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2018/07/09 17:26:39
    • Status: offline
    • Ribbons : 0
    Re: Can anybody help with this 850 G2 problem 2018/07/14 12:25:12 (permalink)
    ok thanx BennyM.
    #14
    Jump to:
  • Back to Mobile