EVGA

CLC 280 - Pump not being detected [Screenshots attached]

Author
cookingplots
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2020/09/27 10:27:26
  • Status: offline
  • Ribbons : 0
2021/05/11 16:15:54 (permalink)
Hello,
 
I believe I am having issues with the CLC 280’s firmware.
 
To start off for reference, my specs are as follows; (

CPU:                    AMD Ryzen 9 5900X 3.7 GHz 12-Core Processor
CPU Cooler:          EVGA CLC 280 113.5 CFM Liquid CPU Cooler
Motherboard:        Gigabyte X570 AORUS ELITE WIFI ATX AM4 Motherboard
RAM:                    Corsair Vengeance RGB Pro 32 GB (4 x 8 GB)
Storage:               Samsung 750 Evo 500 GB 2.5" Solid State Drive
                           Samsung 860 Evo 250 GB 2.5" Solid State Drive
                           Samsung 970 Evo 1 TB M.2-2280 NVME Solid State Drive
GPU:                    Gigabyte GeForce RTX 3080 10 GB GAMING OC Video Card
Case:                   Rosewill RISE ATX Full Tower Case
PSU:                    EVGA GQ 750 W 80+ Gold Certified Semi-modular ATX Power Supply
 
I recently upgraded my rig and swapped out the Motherboard and CPU (From an ASRock Z390 Pro4 and i7 8700k, respectively). Prior to making this change, my CLC 280’s pump speeds were set to idle; In other words very low. After the forementioned upgrade, I no longer have the ability to open and use EVGA’s Flow Control. I get the “Device not found.” message. I’ve searched through various forum posts but to no avail. I’m now hard-stuck with an idle pump.
 
When opening the Device Manager, the CLC 280 is recognized by my computer as “Unknown USB Device (Device Descriptor Request Failed)”. I’ve tried replugging the device into another USB Header on the motherboard, but this did not fix the issue. Based off other forum posts, I believe it should read “CCIV”.
 
I have tried almost everything from uninstalling and reinstalling EVGA Flow Control, uninstalling the drivers, setting the CLC 280’s fan speeds to 100% in the BIOS, switching USB headers on the Motherboard, and everything in between.
 
I believe the closest I’ve come to a solution is from MazerRackham’s post; (), where he mentions: “The installer uses a /system32/pnp.exe on the ccvi.inf. When you delete the driver, the registry entries are left - meaning if you re-install, the installer thinks its already installed and does not reinstall the driver, leaving your computer with the fans spinning at 100% and the pump at whatever it was at last before it crashed.”
 
This seems the closest to the problem I’m having, however his solution was to reinstall Windows altogether. I’ve searched for the CCVI.inf registry key in the registry editor, but I cannot delete it. I want to avoid reinstalling Windows as well – I’m hoping there is a more logical solution.
 
05/12 Update: 
I reinstalled Windows and still nothing. All previous drivers and registry keys were wiped, but the CLC 280 is still showing up as “Unknown USB Device (Device Descriptor Request Failed)”, even after installing EVGA's Flow Control.  Any help at all would be greatly appreciated. 
 
05/18 Update:
Unfortunately, after many service tickets opened and other forum posts - it seems the only solution I was able to get to is to RMA the CLC 280. I've opened an RMA request and will be cross-shipping a new cooler. Hopefully this really is an issue with the firmware on the pump & replacing it with a new one will fix the issue. I will keep you guys posted.
 
 
post edited by cookingplots - 2021/05/18 13:37:12

Attached Image(s)

#1

2 Replies Related Threads

    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 26008
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 119
    Re: CLC 280 - Pump not being detected [Screenshots attached] 2021/05/14 11:00:50 (permalink)

    RTX Project EVGA X99 FTWK 2xEVGA2080Ti EVGA1200P2  Nibbler EVGA X99 Classified 3-GPU Water cooled 1600P2 AIO Folding  X99 2x1080Ti FTW3 Hybrid, 1200P
    Thank You for Your Support      I'm a Volunteer Moderator on the EVGA Forums ... Not an EVGA employee

    #2
    cookingplots
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2020/09/27 10:27:26
    • Status: offline
    • Ribbons : 0
    Re: CLC 280 - Pump not being detected [Screenshots attached] 2021/05/14 18:04:46 (permalink)
    Hi Cool GTX,

    Thanks for your reply. 
     
    The FAQs were my first stop when trying to troubleshoot. Just for safe measures I attempted the suggested fix again and still nada. 
     
    I'm currently in contact with EVGA as well. They suggested I install IObit Uninstaller and use that program to completely remove EVGA Flow Control and reinstall its drivers. Unfortunately, this did not work either.. lol. Will keep the forum posted.
     
    Thanks,
    #3
    Jump to:
  • Back to Mobile