EVGA

Adaptive Power Management == choppy 60fps with SLi GTX 680s

Author
raf.the.stampede
New Member
  • Total Posts : 40
  • Reward points : 0
  • Joined: 2007/06/21 21:05:33
  • Status: offline
  • Ribbons : 0
2012/06/14 18:47:29 (permalink)
I have noticed that with any game that I run (currently I have Skyrim, Diablo 3, Dota 2 & WoW installed) while enabling the Adaptive Power Management settings in the NVIDIA display panel, I experience very undesirable results with my frames per second in-game.  I play my games with maxing out as much of the graphics that I can with V-Sync with Triple Buffering on, and while I am shown to be running at constant 60 frames per second, it doesn't feel as smooth as it should be, considering my current rig:
 
Intel i7 970 hexa-core CPU O/C@3.71GHz
Corsair DOMINATOR GT 6GB DDR3 triple-channel RAM clocked@1600MHz
two EVGA GTX 680s in SLi (both are part #: 02G-P4-2680-KR; they are not O/C'd)
EVGA X58 3-Way SLI CLASSIFIED motherboard (part #:141-BL-E760-A1)
ASUS Xonar Xense 7.1 soundcard kit
two Intel 80GB SSDs (one for OS, one for games)
Enermax Galaxy EVO 1250W PSU
 
I am fully aware of "micro-stutter" and have learned to live with that when it shows itself, but this choppiness is different.  After staying up for most of the night troubleshooting (swapping GPU slots, swapping power cables, testing each card individually, tweaking with Precision X and Afterburner, etc...) I have found the only solution to smooth out my gameplay is changing the Power Management to "Prefer maximum performance".  I also have V-Sync set to "Adaptive" for each game profile, which is awesome IMHO.
 
My theory is that with my current O/C, the system probably doesn't like the constant fluctuation of the voltage on both cards when GPU Boost is triggering while using the Adaptive power management setting.  Both cards are running at superb temperatures in-game, ranging from low 50C up to low-to-mid 70C.  OC Scanner X shows no artifacts or errors with its stress test (I let it run overnight, albeit quitting after its default 2 hour cutoff).
 
I was curious if anyone with GTX 600 series GPUs in SLi might have any input about this, and are you also seeing similar results.    ^_^;
#1

15 Replies Related Threads

    schulmaster
    iCX Member
    • Total Posts : 412
    • Reward points : 0
    • Joined: 2011/06/27 19:48:02
    • Status: offline
    • Ribbons : 6
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/06/14 19:00:41 (permalink)
    Welcome to Kepler! Nvidia is currently testing a fix that corrects this choppiness, which has come to be referred to as the stutter bug. It is not likely it is your power management mode that is the culprit, but rather your having Vsync enabled.
    You can follow the saga here:http://forums.nvidia.com/index.php?showtopic=226227
     
    Should be around two weeks until a Windows 7 Driver is out. However a Windows 8 Driver that contains the fix was released today, and results have been mixed at best as to the patch effectiveness.

    --InWin LE S-Frame #111/500--
    Asus Rampage IV Black Edition--
    i74960x@4.4GHz(1295mV) --
    Corsair H100i w/2X Noctua NF-F12s --
    32GB KingstonHyprXw/QDChannel1866MHzCL9--
    2X 1080Ti FTW3(s) SLI-- 
    27inch 2560x1440 Acer Predator IPS GSYNC--
    2x 1TB Crucial M550 SSDs RAID0 (OS) --
    --4TB WD Enterprise (MISC Storage)--
    --1TB 10000RPM Vraptor(Above Avg Mass Strge)
    --Creative X-Fi Titanium HD-- 
    --Corsair AX1500i--  
    #2
    hellshocker
    Superclocked Member
    • Total Posts : 163
    • Reward points : 0
    • Joined: 2009/10/05 07:02:45
    • Status: offline
    • Ribbons : 1
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/06/14 19:04:59 (permalink)
    Have you tried turning off V-Sync and Triple Buffering and setting Prefer maximum performance then set target frame rate to 60 I think  their is a problem with the drivers right now when using V-Sync the next set of drivers should fix it.

    P55 Classified 200,  CPU: I7 875k @ 4.2 GHz's, EVGA GTX 980 ti hybrid + Obsidian 900D, EK Supreme HF block, black ice gtx xtreme 360,  corsair dominator platinum 8GB 1600MHz,  sound blaster X-Fi Titanium Fatal1ty, supernova 1000 p2.
    #3
    raf.the.stampede
    New Member
    • Total Posts : 40
    • Reward points : 0
    • Joined: 2007/06/21 21:05:33
    • Status: offline
    • Ribbons : 0
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/06/14 19:14:20 (permalink)
    hellshocker
    Have you tried turning off V-Sync and Triple Buffering and setting Prefer maximum performance then set target frame rate to 60 I think  their is a problem with the drivers right now when using V-Sync the next set of drivers should fix it.

     
    No, I haven't tried that with these cards, but I recall setting the frame limit on another system I had in the past and gotten undesirable results with screen tearing showing more often than I was expecting it would.  Still, I'll give it a go later tonight and update with results.
     
    ... I just <3 V-sync + Triple Buffering.  They're like peas in a pod with the right hardware.  Using my current settings, I get little to no hiccups.  I am experiencing a weird texture "flicker" in-game that happens so seldom and random I can not reproduce it, but like I said, no problems with the stress test, so I am leaning that it might be a driver issue, or just sensitivity due to my O/C'd system with the voltage flux caused by GPU Boost.
    #4
    schulmaster
    iCX Member
    • Total Posts : 412
    • Reward points : 0
    • Joined: 2011/06/27 19:48:02
    • Status: offline
    • Ribbons : 6
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/06/14 19:33:52 (permalink)
    raf.the.stampede




    ... I just <3 V-sync + Triple Buffering.  They're like peas in a pod with the right hardware.  

    Triple Buffering is only applied in OpenGL. DirectX games, ie what you're playing, will not utilize Triple Buffering. The 'placebo' setting is a powerful one, though, so enable away.

    --InWin LE S-Frame #111/500--
    Asus Rampage IV Black Edition--
    i74960x@4.4GHz(1295mV) --
    Corsair H100i w/2X Noctua NF-F12s --
    32GB KingstonHyprXw/QDChannel1866MHzCL9--
    2X 1080Ti FTW3(s) SLI-- 
    27inch 2560x1440 Acer Predator IPS GSYNC--
    2x 1TB Crucial M550 SSDs RAID0 (OS) --
    --4TB WD Enterprise (MISC Storage)--
    --1TB 10000RPM Vraptor(Above Avg Mass Strge)
    --Creative X-Fi Titanium HD-- 
    --Corsair AX1500i--  
    #5
    ikeyes
    FTW Member
    • Total Posts : 1864
    • Reward points : 0
    • Joined: 2005/12/08 10:25:17
    • Status: offline
    • Ribbons : 9
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/06/14 20:26:59 (permalink)
    Leave Adaptive Power for Global Settings and then set Prefer Maximum Performance for each individual game by creating profiles in the NVCP.  
     


    3770K @ 4.5 (EVO)|EVGA GTX-670 FTW SLI|ASUS P8Z77-V Deluxe|16GB Vengeance DDR3-1600|830 Series 256GB SSD
    2D Surround @ 6048x1080 on ASUS VH236H (x3) & Dell 2405FPW @ 1920x1200 Accessory Display
    ***********************************************************************************************
    Q6700 @ 3.8 on Swiftech GTZ - EVGA GTX-280 SLI @ 756/1566/1350 on Swiftech MCW60r2 & GTX200 Heatsinks
    EVGA 780i P08 & Zalman ZM-1000HP - HAF-932 - Dual Loop CPU/GPU each with MCR320 & D5 (7/16" Masterkleer) Pentosin G11 1:9 & PTNuke
    ***********************************************************************************************
    Surround Gamer?  This is a must have!  https://www.flawlesswidescreen.org/index.php/Flawless_Widescreen
    #6
    raf.the.stampede
    New Member
    • Total Posts : 40
    • Reward points : 0
    • Joined: 2007/06/21 21:05:33
    • Status: offline
    • Ribbons : 0
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/06/15 01:26:58 (permalink)
    ikeyes
    Leave Adaptive Power for Global Settings and then set Prefer Maximum Performance for each individual game by creating profiles in the NVCP.  

     
    I have already been doing that since my testing last night.  I just finished trying out hellshocker's suggestion with setting the target frame rate to 60 using Precision X, and sure enough, all my games are usually running way over 60fps, resulting in a lot of screen tearing.  Knowing that this is indeed a driver problem, I don't mind waiting for the update and will continue using Adaptive V-sync with Triple Buffering enabled.
     
    A related question arose when reverting my graphics settings.  Should I go ahead and enable Adaptive V-Sync and Triple Buffering in the NVIDIA Control Panel alongside all of my game video settings menus?  For example, WoW has a V-Sync option (although not Adaptive in-game) as well as a Triple Buffering option in its own video menu.  Does it matter if both locations have the options enabled, or should you chose one or the other?  What is the general consensus on this topic?
    #7
    trek554
    SSC Member
    • Total Posts : 785
    • Reward points : 0
    • Joined: 2006/04/24 03:01:37
    • Status: offline
    • Ribbons : 0
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/06/15 01:48:17 (permalink)
    its not just vsync that is an issue with these cards. they cannot stay at ANY framerate that you limit it to whether that's using vsync, framerate target or a framerate limiter. no matter what it will drop 1 fps below that every few seconds in every game for no reason at all. heck you can just stand still and it will do it.  it only took me a few minutes to see this issue so how did every person at Nvidia miss it?  I really hope this crap gets fixed on the next driver or the card is going back. 
     
     


     
    post edited by trek554 - 2012/06/15 01:51:24

    Win 10 Home | 4770k@4.3 | ASUS Z87 Pro | EVGA GTX 1080 ACX 3.0 | G.SKILL 32GB DDR3 2133 | Samsung Evo 850 2TB SSD | CM MasterCase Pro 5 | EVGA SuperNOVA P2 750 watt | Sound Blaster Zx
    #8
    jgonz
    iCX Member
    • Total Posts : 322
    • Reward points : 0
    • Joined: 2009/04/16 07:18:13
    • Status: offline
    • Ribbons : 1
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/06/15 05:57:12 (permalink)
    My NCP settings:Power management = Prefer Maximum Performance. Antialiasing= 8xSuper Sample. V-Sync On. Everything else at default.

    In Battlefield 3 I turn off V-Sync, Motion Blur, and Aliasing Post.
    I don't like the way the game looks with aliasing post and motion blur on.

    Everything else in BF3 is set to Ultra with 4x MSAA @ 1920x1080. My game runs a consistent. 60 fps in a 64 player multiplayer match on Caspian Border. No lag no stutters. If I drp fps its maybe to 58 fps and that is when the game menu for changing loadouts or class. CPU and SLI cards all at stock settings.

    ASUS x99-A
    i7 5820k @ 4.5 GHz
    Corsair Vengeance LPX 16 GB
    2800mhz (@ 2800 MHz)
    240 gig Intel 530 SSD 
    NVIDIA RTX 2080 Founders Edition
    Klipsch Pro Media 2.1 Speakers
    2x 1T Storage Hard Drives
    EVGA SuperNOVA 1000 G2
    Asus PG278Q RoG Swift 144hz G-Sync
    LOGITECH G PRO Keyboard
    Razer Deathadder Mouse
    #9
    raf.the.stampede
    New Member
    • Total Posts : 40
    • Reward points : 0
    • Joined: 2007/06/21 21:05:33
    • Status: offline
    • Ribbons : 0
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/06/15 08:50:15 (permalink)
    trek554
    its not just vsync that is an issue with these cards. they cannot stay at ANY framerate that you limit it to whether that's using vsync, framerate target or a framerate limiter. no matter what it will drop 1 fps below that every few seconds in every game for no reason at all. heck you can just stand still and it will do it.  it only took me a few minutes to see this issue so how did every person at Nvidia miss it?  I really hope this crap gets fixed on the next driver or the card is going back. 

     
    Have you tried using MSI Afterburner?  It has an option you can enable in its General tab under Properties called "Force constant voltage", which EVGA Precision X does not include.  I believe it will stop your card from taking advantage of its GPU Boost, but might help stabilize your frames per second when using V-Sync.  I have yet to do much testing with this.
     
    Then again, even with previous GPUs, V-Sync never fully locks your frames per second, as there will always be slight fluctuations in your performance regardless.  I have noticed with WoW that enabling Adaptive V-Sync in the NVIDIA Control Panel along with turning V-Sync on in the game menu gives me more of a stable lock at 60fps then just depending on the NVIDIA Control Panel alone.  If you are only using the NVIDIA Control Panel for V-Sync, try enabling it in your game menu as well and see if it helps.
    #10
    trek554
    SSC Member
    • Total Posts : 785
    • Reward points : 0
    • Joined: 2006/04/24 03:01:37
    • Status: offline
    • Ribbons : 0
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/06/15 12:11:54 (permalink)
    raf.the.stampede

    trek554
    its not just vsync that is an issue with these cards. they cannot stay at ANY framerate that you limit it to whether that's using vsync, framerate target or a framerate limiter. no matter what it will drop 1 fps below that every few seconds in every game for no reason at all. heck you can just stand still and it will do it.  it only took me a few minutes to see this issue so how did every person at Nvidia miss it?  I really hope this crap gets fixed on the next driver or the card is going back. 


    Have you tried using MSI Afterburner?  It has an option you can enable in its General tab under Properties called "Force constant voltage", which EVGA Precision X does not include.  I believe it will stop your card from taking advantage of its GPU Boost, but might help stabilize your frames per second when using V-Sync.  I have yet to do much testing with this.

    Then again, even with previous GPUs, V-Sync never fully locks your frames per second, as there will always be slight fluctuations in your performance regardless.  I have noticed with WoW that enabling Adaptive V-Sync in the NVIDIA Control Panel along with turning V-Sync on in the game menu gives me more of a stable lock at 60fps then just depending on the NVIDIA Control Panel alone.  If you are only using the NVIDIA Control Panel for V-Sync, try enabling it in your game menu as well and see if it helps.
    gpu boost has nothing to do with it. voltage and clocks can remain constant and it will still happen. it can happen no matter where or how vsync or any type of framerate cap is enabled.  its a driver issue as even capping a game at 30 fps will still result in it dropping to 29 fps every few seconds even just standing still.  


    Win 10 Home | 4770k@4.3 | ASUS Z87 Pro | EVGA GTX 1080 ACX 3.0 | G.SKILL 32GB DDR3 2133 | Samsung Evo 850 2TB SSD | CM MasterCase Pro 5 | EVGA SuperNOVA P2 750 watt | Sound Blaster Zx
    #11
    jbgrobler
    Superclocked Member
    • Total Posts : 128
    • Reward points : 0
    • Joined: 2012/04/09 16:28:40
    • Location: Toronto, Canada
    • Status: offline
    • Ribbons : 1
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/06/15 13:23:30 (permalink)
    Adaptive power management has not produced stuttering for me yet. Vertical sync (adaptive) definitely has.
     
    Personally:
    • Use 3D application setting as default and for games that have the VSync option built in.
    • Force on for games that do not have the VSync option available.
    • Adaptive is a good idea but bad execution. If you really want to see stuttering then enable this! *Shudder!* It seems like the driver does not adapt nearly fast enough to a change in FPS to make this work properly. That part of the driver code needs some serious optimization. If the FPS remain 60 or over (my monitor refresh rate) then all is well. One drop below 60 FPS and is stutters and tears for a few very annoying moments. The more frequent the drop below 60 FPS, the worse it gets. Force VSync on still has some stutter but is far smoother and playable for me.
    Keep your defaults to the nVidia settings and override them per application as required, the driver will load the application settings when it detects the EXE being run.

    Windows 10 Anniversary (Version 1607 Build 14393.447)
    EVGA X79 DARK (150-SE-E789-K2) Firmware v2.13 | Intel i7-3820 (BX80619I73820)
    EVGA GTX 1080 FTW DT (08G-P4-6284-KR) - Driver v375.95
    Corsair HX850W (CMPSU-850HX) | G-Skill Ripjaw 32GB (F3-2133C10D-16GXM)
    CM Storm Trooper (SGC-5000-KKN1) | Pioneer BDR-20 | RealTek HD Audio v6.0.1.7940
    WD Caviar Black 500G x2 (WD5002AALX) - Intel RSTe (RAID0) v13.2.0.1022
    ASMedia ASM1042 Driver v1.16.35.1
    #12
    siccmade11
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2012/06/26 16:20:01
    • Status: offline
    • Ribbons : 0
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/07/13 11:19:44 (permalink)
    This is EXACTLY what i see when monitoring my FPS with precision. In BF3 with vsync on watching my frames with precision i see 60.1>59.1<60.1>59.1 and the graph looks like a heart rate monitor going up and down constantly its very annoying.  this happens with my hand off the mouse and staring at a wall.  I have a gtx 690 and a i7 2700k @5GHZ.  This causes a very slight stutter and really hope it will be fixed.  I am currently running 304.79 beta driver.  The weird thing is when monitoring my FPS in game with "render.drawfps 1" its locked at 60 the whole time.....
    #13
    flyhii
    Superclocked Member
    • Total Posts : 182
    • Reward points : 0
    • Joined: 2008/11/26 20:58:38
    • Location: Farmington, NM
    • Status: offline
    • Ribbons : 2
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/07/13 15:46:59 (permalink)
    I may suggest to try resetting the "Max Prerendered Frames" from "Use the 3D Application Setting" to a number. This used to be default set to 3 in previous release drivers until the R300 series drivers (for the 600 series cards). I think that this new default was added due to some newer games that have coding in the game to "set" this. Even w/ the newest DDR3 OC system mem it ain't even close to the GDDR5 insanely OC vid card mem so some of this stuttering I believe is coming from the Kepler GPU being at a 1-to-1 ratio to the CPU (this is what I think is happening when the driver isn't instructed from the game so it defaults to a 1-to-1 ratio).
     
    I reset this on my box (in sig) from default to 2---this stopped the stuttering completely........w/ Adaptive Power Management enabled.
     
    YMMV
     

    MS Win 7 Home Premium 64x SP1
    Intel I7 4820K IB-E CPU  
    ASUS Rampage IV Gene X79 mobo  
    Mushkin Stealth LP 16Gb 4x4Gb DDR3 2133 QC mem
    Sapphire R9 Fury X 4Gb HBM vid card 
    1 Plextor M6e BK 512Gb PCI-E SSD (boot)
    1 OCZ Vertex 4 256Gb SATAIII SDD (storage)
    Creative SoundBlaster Zx SS card  
    Intel Gbit LAN
    Corsair TX 850 SLI PSU
    DoubleSight DS-279W 27" 2560x1440 monitor
    CM Storm Scout Mid ATX Gaming Case
    #14
    Dunlin1
    New Member
    • Total Posts : 51
    • Reward points : 0
    • Joined: 2008/12/27 18:37:50
    • Status: offline
    • Ribbons : 0
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/07/13 18:02:42 (permalink)
    I get stuttering goes from 120 fps to 17 fps or less(know matter what settings are at) for the first 20 minutes pc is on then it is 100% fine? Is it drivers or is the card bad this is my second card EVGA gtx 680 FTW 4gb.(first was galaxy gtx 680 RMA stuttered all the time). I am starting to think there is a design flaw in the 600 series.
     
    #15
    trek554
    SSC Member
    • Total Posts : 785
    • Reward points : 0
    • Joined: 2006/04/24 03:01:37
    • Status: offline
    • Ribbons : 0
    Re:Adaptive Power Management == choppy 60fps with SLi GTX 680s 2012/07/13 18:26:21 (permalink)
    siccmade11

    This is EXACTLY what i see when monitoring my FPS with precision. In BF3 with vsync on watching my frames with precision i see 60.1>59.1<60.1>59.1 and the graph looks like a heart rate monitor going up and down constantly its very annoying.  this happens with my hand off the mouse and staring at a wall.  I have a gtx 690 and a i7 2700k @5GHZ.  This causes a very slight stutter and really hope it will be fixed.  I am currently running 304.79 beta driver.  The weird thing is when monitoring my FPS in game with "render.drawfps 1" its locked at 60 the whole time.....
    that is perfectly normal and will happen on ANY card as its just the way that precision shows the framerate. and that is NOT what is causing your stutter.  


    Win 10 Home | 4770k@4.3 | ASUS Z87 Pro | EVGA GTX 1080 ACX 3.0 | G.SKILL 32GB DDR3 2133 | Samsung Evo 850 2TB SSD | CM MasterCase Pro 5 | EVGA SuperNOVA P2 750 watt | Sound Blaster Zx
    #16
    Jump to:
  • Back to Mobile