EVGA

Hot!850GQ 2° rma and still does not work

Author
nicegab
New Member
  • Total Posts : 11
  • Reward points : 0
  • Joined: 2019/02/28 13:14:56
  • Status: offline
  • Ribbons : 0
2019/11/30 05:07:18 (permalink)
hello
 
my 850GQ left in rma for the first time in February

 
a second time in novembre....same problem

 
I received the news yesterday ...don't work


inadmissible .... and 22 euros return fee each time

I bought evga for the reputation of his sav .....bull
post edited by the_Scarlet_one - 2019/12/03 12:57:52
#1

15 Replies Related Threads

    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 19584
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: online
    • Ribbons : 114
    Re: 850GQ 2° rma and still does not work 2019/11/30 06:58:48 (permalink)
    Moving to Warranty Section of Forums
     
    Home » All Forums » [EVGA General Forum] » EVGA Warranty Questions

    RTX Project EVGA X99 FTWK-5930K,EVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 3-GPU Water Loop 1600P2  AIO Folding  1080Ti FTW3 Hybrid, 1200P
    Thank You for Your Support


    #2
    nicegab
    New Member
    • Total Posts : 11
    • Reward points : 0
    • Joined: 2019/02/28 13:14:56
    • Status: offline
    • Ribbons : 0
    Re: 850GQ 2° rma and still does not work 2019/11/30 07:04:33 (permalink)
    Why ?

    my post is to show that these power supply are very bad ..... as well as the SAV ....
    3 outages in 8 months .... it's more of a coincidence
    #3
    rjohnson11
    EVGA Forum Moderator
    • Total Posts : 75374
    • Reward points : 0
    • Joined: 2004/10/05 12:44:35
    • Location: Europe
    • Status: offline
    • Ribbons : 70
    Re: 850GQ 2° rma and still does not work 2019/11/30 07:11:28 (permalink)
    I have forwarded this thread to EVGA

    Specs: AMD Ryzen 9 3950X,  Corsair MP600 M.2, 64GB Corsair RGB Dominator,  ASUS Crosshair VIII Hero,  Corsair 1000D, EVGA RTX 2080ti Black

    Associate Code: H5U80QBH6BH0AXF



    #4
    nicegab
    New Member
    • Total Posts : 11
    • Reward points : 0
    • Joined: 2019/02/28 13:14:56
    • Status: offline
    • Ribbons : 0
    Re: 850GQ 2° rma and still does not work 2019/11/30 07:21:50 (permalink)
    why do ... still a rma ... still talk to a guy who resists phrases like a robot ....


    The power supply cost me more than 100 euros in February 2018 + 22 euros return charge in February 2019 + 22 euros return charge in November 2019 ....

    it's normal for evga...everything is good...
    #5
    rjohnson11
    EVGA Forum Moderator
    • Total Posts : 75374
    • Reward points : 0
    • Joined: 2004/10/05 12:44:35
    • Location: Europe
    • Status: offline
    • Ribbons : 70
    Re: 850GQ 2° rma and still does not work 2019/11/30 07:25:10 (permalink)
    nicegab
    why do ... still a rma ... still talk to a guy who resists phrases like a robot ....

    The power supply cost me more than 100 euros in February 2018 + 22 euros return charge in February 2019 + 22 euros return charge in November 2019 ....

    it's normal for evga...everything is good...

    I have forwarded this to EVGA so they can decide what they should do. Keep in mind that EU EVGA doesn't work on the weekends and EVGA is the USA is also not working this weekend as well. 

    Specs: AMD Ryzen 9 3950X,  Corsair MP600 M.2, 64GB Corsair RGB Dominator,  ASUS Crosshair VIII Hero,  Corsair 1000D, EVGA RTX 2080ti Black

    Associate Code: H5U80QBH6BH0AXF



    #6
    nicegab
    New Member
    • Total Posts : 11
    • Reward points : 0
    • Joined: 2019/02/28 13:14:56
    • Status: offline
    • Ribbons : 0
    Re: 850GQ 2° rma and still does not work 2019/11/30 07:29:03 (permalink)
    that fun....my pc also will not work this weekend ....
     
     
    #7
    EVGATech_MarkusK
    EVGA EU Tech Support
    • Total Posts : 219
    • Reward points : 0
    • Joined: 2013/05/28 08:56:25
    • Status: offline
    • Ribbons : 0
    Re: 850GQ 2° rma and still does not work 2019/12/02 01:52:23 (permalink)
    Hi,
     
    we contacted you back through your support ticket - please get back to us either through ticket or supporteu@evga.com
     
    Regards,
    Markus
    #8
    nicegab
    New Member
    • Total Posts : 11
    • Reward points : 0
    • Joined: 2019/02/28 13:14:56
    • Status: offline
    • Ribbons : 0
    Re: 850GQ 2° rma and still does not work 2019/12/03 07:14:16 (permalink)
    to be transparent
    evga refuses to refund the power supply .... and offers to refund the shipping costs ....
    but he does not tell me if it is the first return, the second return, 2 returns ..... or 2 returns + the new to come ....
    so I asked them the question .... no answer since yesterday .....

    welcome in evga world...
    #9
    zeronixpt
    New Member
    • Total Posts : 8
    • Reward points : 0
    • Joined: 2019/09/10 10:13:08
    • Status: offline
    • Ribbons : 0
    Re: 850GQ 2° rma and still does not work 2019/12/15 09:17:13 (permalink)
    Same problem here:
     
    Check my post from october:
    forums.evga.com/RMA-Returned-me-an-Damaged-Power-Supply-m2998439.aspx#2998439
     
    Regards
    #10
    nicegab
    New Member
    • Total Posts : 11
    • Reward points : 0
    • Joined: 2019/02/28 13:14:56
    • Status: offline
    • Ribbons : 0
    Re: 850GQ 2° rma and still does not work 2019/12/23 03:55:03 (permalink)
    new power supply finally received after 2 weeks ..... it works finally but until when ....

    so to summarize 3 HS power supplies in 8 months (including one on receipt) ..... more than 4 weeks without a pc ..... 3 paid returns (22 euros each time)
     Finally EVGA made no gesture and only refund me for one return on the 3 made.....

    shame on you EVGA .... it's not a way to treat customers ....

    anyway this is my last time with you


    post edited by nicegab - 2019/12/23 05:40:29
    #11
    zeronixpt
    New Member
    • Total Posts : 8
    • Reward points : 0
    • Joined: 2019/09/10 10:13:08
    • Status: offline
    • Ribbons : 0
    Re: 850GQ 2° rma and still does not work 2019/12/23 11:00:24 (permalink)
    nicegab
    new power supply finally received after 2 weeks ..... it works finally but until when ....

    so to summarize 3 HS power supplies in 8 months (including one on receipt) ..... more than 4 weeks without a pc ..... 3 paid returns (22 euros each time)
    Finally EVGA made no gesture and only refund me for one return on the 3 made.....

    shame on you EVGA .... it's not a way to treat customers ....

    anyway this is my last time with you






    I understand you completely,
     
    Same passed with me, but i choose to take a loss,
     
    Will not send and pay the shipping to evga to return an random DOA used power supply again,
     
    Evga was my last time too..
     
    I posted too what passed in yotube on my 1M channel, they will/have loose a lot of costumers too..
     
    Happy christmas
    #12
    nicegab
    New Member
    • Total Posts : 11
    • Reward points : 0
    • Joined: 2019/02/28 13:14:56
    • Status: offline
    • Ribbons : 0
    Re: 850GQ 2° rma and still does not work 2019/12/24 01:56:43 (permalink)
    thank you for supporting zeron ixpt

    I also started to share my bad experience with EVGA on French hardware forums (video and copy of conversations with the after-sales service).

    people need to know that EVGA's after-sales service is completely incompetent and doesn't care about the buyers...just good at reciting pre-recorded sentences...I wonder if we're not dealing with a bot...

    moreover there is clearly a problem with some of their products but instead of admitting it and fixing their mistakes they act as if nothing had happened...
    #13
    nicegab
    New Member
    • Total Posts : 11
    • Reward points : 0
    • Joined: 2019/02/28 13:14:56
    • Status: offline
    • Ribbons : 0
    Re: 850GQ 2° rma and still does not work 2019/12/27 02:55:37 (permalink)
    really you have a funny way of satisfying the customer at EVGA...

    By dint of chatting with the after-sales service I get this message:
    "as a gesture of customer satisfaction our RMA manager has agreed to cover shipping for the recent RMA"

    and as in previous discussions I've been told that:
    "We can only cover shipping for those product failed within 30 days of shipping."

    I said to myself ok, EVGA will reimburse me for the sending of my power supply in rma + the return of the power supply received out of order.............well no

    only one refund....EVGA is simply enforcing its return policy by making it look like a gesture to satisfy the customer...

    you're pathetic EVGA


    #14
    EVGATech_AdamB
    Administrator
    • Total Posts : 1390
    • Reward points : 0
    • Joined: 2017/06/05 00:00:00
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 4
    Re: 850GQ 2° rma and still does not work 2019/12/27 09:23:14 (permalink)
    Hello nicegab! Sorry to hear about the issues you have been experiencing with your power supplies. I have reached out to our EU team to make sure we are doing everything we can to make sure you get a working unit. I will send you an e-mail so you can follow up with me directly.

    Like our service? Please provide feedback for us at the link HERE
    #15
    nicegab
    New Member
    • Total Posts : 11
    • Reward points : 0
    • Joined: 2019/02/28 13:14:56
    • Status: offline
    • Ribbons : 0
    Re: 850GQ 2° rma and still does not work 2020/01/06 01:06:16 (permalink)
    come on, I'll give news...
    despite the help of AdamB, nothing progresses...
    I just had an unreal e-mail exchange with support...
    they propose a return...I answer that the last power supply works and that I just want a refund of the shipping costs.......so they propose me a return......funny

    #16
    Jump to:
  • Back to Mobile