EVGA

2080ti XC Ultra vBIOS wont update/flash with EVGA tools

Author
gsrcrxsi
Superclocked Member
  • Total Posts : 143
  • Reward points : 0
  • Joined: 2010/01/24 19:20:59
  • Status: offline
  • Ribbons : 0
2021/01/12 17:06:00 (permalink)
I have a 2080ti XC Ultra (11G-P4-2383-KB) here that is having some issues. I bought it second hand. the previous owner says "it worked fine for me" which seems hard to believe, but since the card DOES function and run games/tests, it wouldn't surprise me if it was someone who didn't know much about computers and what the performance is supposed to be like.
 
1. the core clock is locked at 1350MHz under load, memory locked at 7000MHz. it downclocks to like 3-400MHz at idle still. fan function seems fine. it will run benchmarks and applications/games, just with poor performance (for a 2080ti) due to the clock issues. thermals are totally fine. fans barely spin up and the card stays around 59C at 40% fanspeed under load. GPUz reports 0% TDP under load, and volts seem locked at 0.713v. perfcap stuck on "Idle" under load. I tried DDU + driver update, but no dice. same issue. any attempt to manual overclock via PX1 is an immediate crash.
 
2. the LED lights don't work. at all. PX1 doesn't even recognize that they are there. the LED menu is not even there in PX1 (version 1.1.4).
 
I did check over the PCB to look for signs of modding, but unless this dude can solder like the factory, I don't think it's been touched, the power plug shunts look factory and nothing else on the PCB looks otherwise wrong or damaged or modded/etc.
 
my next thought was to try flashing the vBIOS Current BIOS version is 90.02.17.00.7D according to GPUz, and that matches the sticker on the PCB. maybe there was some corruption or something. I tried using the BIOS flash here from the forums: https://forums.evga.com/EVGA-GeForce-RTX-2080-Ti-2080-XCXC-Ultra-BIOS-Update-m2858793.aspx but it gives me an error saying: "ERROR: Error attempting to map adapter (0x00000005) Detailed :Access is denied." YES i ran it as administrator. I've run this same update on other 2080ti XC Ultras I have here and they all worked fine. but this card hits this error.
 
I next contacted support, and I spoke with Peter, and he tried several times to email me an updated BIOS flash tool, but there must be something wrong with their email system because he tried 3x and i never received any email from him. He even had me open a Support ticket to try to send me the file that way, and still nothing, I could see his reply on the website, but no file attached. and no email.
 
So I hope this post catches the eye of someone at EVGA and they can post up an updated BIOS flash tool that I can try for this card. It's the last thing I'd like to attempt before throwing in the towel and RMA-ing the card.
#1

5 Replies Related Threads

    Sajin
    EVGA Forum Moderator
    • Total Posts : 44098
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 197
    Re: 2080ti XC Ultra vBIOS wont update/flash with EVGA tools 2021/01/13 02:06:36 (permalink)
    Since evga’s tool doesn’t work for you I would try nvflash instead. You can most likely download your vbios from techpowerup.com/vgabios as well.

    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #2
    aka_STEVE_b
    EGC Admin
    • Total Posts : 15340
    • Reward points : 0
    • Joined: 2006/02/26 06:45:46
    • Location: Wouldn't you like to know....
    • Status: online
    • Ribbons : 54
    Re: 2080ti XC Ultra vBIOS wont update/flash with EVGA tools 2021/01/13 05:38:18 (permalink)
    the '1350' stuck issue is all over the internet.... and/ or read this thread - https://forums.evga.com/FindPost/3198420
     
     
    Sounds like when flashing doesn't show up or work, it's usually RMA time.


    AMD RYZEN 9 3900X  12-core cpu~ Gigabyte X570 Aorus Elite board ~ EVGA RTX 2080 SUPER XC2 ULTRA OC~ G.SKILL Trident Z NEO 16 GB DDR4 3600 ~ Phanteks Eclipse P400s red case ~ EVGA SuperNOVA 1000 G+ PSU ~ Intel 660p M.2 drive~ Crucial MX300 275 Gig SSD ~ CORSAIR H80i v2 cooler ~ CORSAIR Dark Core RGB Pro mouse ~ CORSAIR K68 Mech keyboard ~ HGST 4TB Hd.~ AOC AGON 31.5" monitor 1440 @ 144Hz ~ Win 10 x64 
    ................ GET UP TO A 10% DISCOUNT ON PURCHASES BY CLICKING ....VVVVVVVVV.........


    #3
    gsrcrxsi
    Superclocked Member
    • Total Posts : 143
    • Reward points : 0
    • Joined: 2010/01/24 19:20:59
    • Status: offline
    • Ribbons : 0
    Re: 2080ti XC Ultra vBIOS wont update/flash with EVGA tools 2021/01/13 07:09:19 (permalink)
    Sajin
    Since evga’s tool doesn’t work for you I would try nvflash instead. You can most likely download your vbios from techpowerup.com/vgabios as well.

    I'm hesitant to use nvflash, as I don't want it to jeopardize the ability to RMA the card should it end up bricking the card.
    #4
    gsrcrxsi
    Superclocked Member
    • Total Posts : 143
    • Reward points : 0
    • Joined: 2010/01/24 19:20:59
    • Status: offline
    • Ribbons : 0
    Re: 2080ti XC Ultra vBIOS wont update/flash with EVGA tools 2021/01/13 07:19:43 (permalink)
    aka_STEVE_b
    the '1350' stuck issue is all over the internet.... and/ or read this thread - https://forums.evga.com/FindPost/3198420
     
     
    Sounds like when flashing doesn't show up or work, it's usually RMA time.





    the video you posted in that thread is EXACTLY the symptoms I'm seeing.

    https://www.youtube.com/watch?v=A0dRm5DqHWQ
     
    stuck at 1350MHz - low performance
    any manual OC causes issues and crashing
    Power target stuck at 0
    perf cap stuck at idle
     
    given that everything is the same, I'd say flashing the vbios wont work anyway, since it didn't work for GN
    #5
    Sajin
    EVGA Forum Moderator
    • Total Posts : 44098
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 197
    Re: 2080ti XC Ultra vBIOS wont update/flash with EVGA tools 2021/01/13 17:43:33 (permalink)
    gsrcrxsi
    Sajin
    Since evga’s tool doesn’t work for you I would try nvflash instead. You can most likely download your vbios from techpowerup.com/vgabios as well.

    I'm hesitant to use nvflash, as I don't want it to jeopardize the ability to RMA the card should it end up bricking the card.

    No need to worry about that... https://www.overclock.net...amd-or-nvidia.1612108/

    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #6
    Jump to:
  • Back to Mobile