EVGA

Hot!1080ti SC2 died after RMA

Author
NoobTai
New Member
  • Total Posts : 6
  • Reward points : 0
  • Joined: 2019/05/28 04:49:27
  • Status: offline
  • Ribbons : 0
2019/10/27 06:29:01 (permalink)
Recently i rma a 1080ti . It was artifact, freeze , crash . Evga replace my card with another 1080ti sc2 , i know that this is a refurbished card but the cooler looks very good , the card was working good in first 2 week . Then after that , it was crashing in fusion 360 , I thought that this is the program issues.. but it isn’t. I ran pubg and another 3D programs , it freeze and artifact AGAIN ! even running a youtube video would freeze it . I contacted Evga then they accept to replace it again ( at least this time I don’t need to pay for shipping fees :) . Hope this time it will be good ...
post edited by NoobTai - 2019/10/27 06:38:45
#1

7 Replies Related Threads

    EVGATech_JoseC
    EVGA Tech Support
    • Total Posts : 355
    • Reward points : 0
    • Joined: 2017/06/05 00:00:00
    • Location: EVGA
    • Status: offline
    • Ribbons : 2
    Re: 1080ti SC2 died after RMA 2019/10/28 17:52:28 (permalink)
    Hello,

    Sorry to hear that you experienced issues with your replacement graphics card. Looks like our Taiwan team has helped you start a new RMA and as you said helping you with the shipping fees. If anything comes up, let us know, we are here to help.
    #2
    NoobTai
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2019/05/28 04:49:27
    • Status: offline
    • Ribbons : 0
    Re: 1080ti SC2 died after RMA 2019/10/28 21:56:03 (permalink)
    Yes i currently waiting for them to prepare replacement product. It’s been a day now.
    #3
    dindin631
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2019/03/11 08:43:57
    • Status: offline
    • Ribbons : 0
    Re: 1080ti SC2 died after RMA 2019/11/12 18:27:04 (permalink)
    any update? also had an RMA completed and shipped back out today but the serial number for the replacement on the site is greyed out so i can't see if i got the same card returned or not.  
    #4
    EVGATech_DanielM
    EVGA Tech Support
    • Total Posts : 412
    • Reward points : 0
    • Joined: 2017/07/07 19:01:01
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 1
    Re: 1080ti SC2 died after RMA 2019/11/12 20:01:38 (permalink)
    Hey DinDin631
     
    Looks like they shipped the replacement today and it is the same model you sent in. Looks like they were able to find one in stock. Hope this helps!

     
     
     
    -Daniel_EVGA
    #5
    dindin631
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2019/03/11 08:43:57
    • Status: offline
    • Ribbons : 0
    Re: 1080ti SC2 died after RMA 2019/11/13 07:31:02 (permalink)
    EVGATech_DanielM
    Hey DinDin631
     
    Looks like they shipped the replacement today and it is the same model you sent in. Looks like they were able to find one in stock. Hope this helps!




     
    thanks for the quick help! I rated you 5 stars on the evga website, probably the best type of customer service out of any of the GPU vendors. I honestly didn't think evga would respond so quickly LUL
    #6
    dindin631
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2019/03/11 08:43:57
    • Status: offline
    • Ribbons : 0
    Re: 1080ti SC2 died after RMA 2019/11/22 18:21:05 (permalink)
    So i guess i spoke too son, the rma replacement ended up having issues, it would crash during idle @ menu screen of games it was pretty weird, i am now on my 2nd rma, i already sent in my card and evga rma info says it was received yesterday however today around 5pm i received a return tracking label which obviously came too late for me as i had sent in the card the same day i got the rma approved, will this slow down my rma replacement being sent out? I had my first replacement sent out within 1 day so hopefully i can receive my replacement card before the thanksgiving evga break.
    #7
    EVGATech_DanielM
    EVGA Tech Support
    • Total Posts : 412
    • Reward points : 0
    • Joined: 2017/07/07 19:01:01
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 1
    Re: 1080ti SC2 died after RMA 2019/11/22 18:52:23 (permalink)
    I would recommend setting up a support ticket rather than use someone elses post or starting your own. We do not usually address RMA issues on the forum. Please send that ticket or send us an email direct to support@evga.com 

     
     
     
    -Daniel_EVGA
    #8
    Jump to:
  • Back to Mobile