EVGA

Helpful Reply1050 g Supernova. I broke it.

Author
mkerwin
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2021/01/02 13:08:53
  • Status: offline
  • Ribbons : 0
2021/01/02 13:15:20 (permalink)
Installing a new drive I plugged in the power cable a little crooked. Got a strong ozone smell. I opened the case while it was running and I bumped the loose cable it and the psu shut down. I assume that was a breaker. 


It won’t come back on. No spin up, nothing. Manual doesn’t cover this. Is there a hidden secret to untripping the breaker or did I blow it Forever?
 
thanks for any help you can give. 
#1
Sajin
EVGA Forum Moderator
  • Total Posts : 44306
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 197
Re: 1050 g Supernova. I broke it. 2021/01/02 15:02:58 (permalink) ☄ Helpfulby mkerwin 2021/01/02 15:03:42
Remove the power cable from the drive. Flip the switch on the psu to off then back to on. See if the system will start with the drive unplugged.

Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
 

 
#2
mkerwin
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2021/01/02 13:08:53
  • Status: offline
  • Ribbons : 0
Re: 1050 g Supernova. I broke it. 2021/01/02 15:07:35 (permalink)
Thank you!

I admit I tried this on my own, accidentally. I was checking the UPS to make sure it still worked and unplugged that end of the power. I unplugged all the drives to see if it would start without them. Then I tested the switch and it just came back on. 

Glad I read your post though, because I had no idea what it was I did that worked. I'm going to stop clumsily screwing with things now.
#3
Jump to:
  • Back to Mobile